Vzdrževalna dela, 25.06.2022

Pozdravljeni.

Obveščamo Vas, da smo danes 25.06.2022 od 9:00 do 09:40 ure izvajali redna vzdrževalna dela na strežnikih server, server3 in server4.

Prosimo Vas za razumevanje.


OBVESTILO – PHP 7.1 nadomeščamo s PHP 7.2 (server, server3)

Obveščamo Vas, da bomo vse uporabnike na strežnikih server in server3, kateri uporabljajo PHP 7.1 preklopili na PHP 7.2.

Preklop bomo izvedli 08.06.2022.

Razlog:
– novi operacijski sistem podpora PHP verzije od 7.2 dalje

Predlagamo Vam, da čim prej posodobite spletne strani, da bodo delovale na PHP 7.x. Priporočamo uporabo PHP 7.4.

Hvala za razumevanje!


Navodila – Kako odpraviti napako “The system failed to apply the “PHP” version” pri spremembi PHP verzije

Navodila:

– preimenujte obstoječo datoteko ».htaccess«
– spremenite PHP verzijo
– vsebino iz vaše preimenovane datoteke ».htaccess« prekopirajte v datoteko, katero je kreiralo pri čemer naj bo vaša vsebina nad vsebino kreirane datoteke
– odstranite vašo začasno datoteko ».htaccess«

Napaka:

Error: (XID zqwaxq) 1 error occurred: Error #1: The system failed to apply the “PHP” version to “your-domain.com”: Cpanel::Exception::IO::FileCreateError/(XID 4b55rc) The system failed to create the file “/.htaccess.lock” (as EUID: 527, EGID: 525 525) because of the following error: Permission denied at /usr/local/cpanel/Cpanel/SafeFile.pm line 372. Cpanel::SafeFile::_safelock("/.htaccess") called at /usr/local/cpanel/Cpanel/SafeFile.pm line 553 Cpanel::SafeFile::_safe_open(undef, 66, "/.htaccess", CODE(0x2751f48), "safesysopen") called at /usr/local/cpanel/Cpanel/SafeFile.pm line 210 eval {...} called at /usr/local/cpanel/Cpanel/SafeFile.pm line 209 Cpanel::SafeFile::safesysopen(undef, "/.htaccess", 66, 420) called at /usr/local/cpanel/Cpanel/SafeFile.pm line 124 Cpanel::SafeFile::safesysopen_no_warn_on_fail(undef, "/.htaccess", 66, 420) called at /usr/local/cpanel/Cpanel/Transaction/File/Base.pm line 128 Cpanel::Transaction::File::Base::new("Cpanel::Transaction::File::Raw", "path", "/.htaccess", "permissions", 420, "restore_original_permissions", 1) called at /usr/local/cpanel/Cpanel/WebServer/Supported/apache/Htaccess.pm line 191 Cpanel::WebServer::Supported::apache::Htaccess::_internal_set_handler(Cpanel::WebServer::Supported::apache::Htaccess=HASH(0x1d9d550), "package", "inherit", "handler", Cpanel::WebServer::Supported::apache::Handler::inherit=HASH(0x1d9d5e0), "vhost", "your-domain.com", "userdata", ...) called at /usr/local/cpanel/Cpanel/WebServer/Supported/apache/Htaccess.pm line 212 Cpanel::WebServer::Supported::apache::Htaccess::__ANON__() called at /usr/local/cpanel/Cpanel/AccessIds/ReducedPrivileges.pm line 96 eval {...} called at /usr/local/cpanel/Cpanel/AccessIds/ReducedPrivileges.pm line 96 Cpanel::AccessIds::ReducedPrivileges::call_as_user(CODE(0x2751cf0), 527, 525) called at /usr/local/cpanel/Cpanel/WebServer/Supported/apache/Htaccess.pm line 217 Cpanel::WebServer::Supported::apache::Htaccess::set_handler(Cpanel::WebServer::Supported::apache::Htaccess=HASH(0x1d9d550), "lang", Cpanel::ProgLang::Supported::php=HASH(0x2489210), "package", "inherit", "userdata", Cpanel::WebServer::Userdata=HASH(0x23df7a0), "vhost", ...) called at /usr/local/cpanel/Cpanel/WebServer/Supported/apache.pm line 967 Cpanel::WebServer::Supported::apache::__ANON__(Cpanel::Exception::IO::FileCreateError=HASH(0x26f56d0)) called at /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib/Try/Tiny.pm line 118 Try::Tiny::try(CODE(0x1ad25f0), Try::Tiny::Catch=REF(0x2751f18)) called at /usr/local/cpanel/Cpanel/WebServer/Supported/apache.pm line 973 

Razlog:

Napako javlja, ker ne more spremenite vaše obstoječe ».htaccess« datoteke.


Kako nastaviti FTP odjamalec preko FTPS – varna povezava

FTP strežnik zahteva šifrirano povezavo preko FTPS (SSL/TLS).

Napaka:

Odgovor:421-Sorry, cleartext sessions and weak ciphers are not accepted on this server.Odgovor:421 Please reconnect using TLS security mechanisms.

Rešitev:
V FTP odjemalcu obkljukajte šifrirano povezavo SSL/TLS oz. izberite “Require implicit FTP over TLS”. Predlagamo Vam, da se povezujete na ime strežnika z veljavnim SSL certifikatom.

Filezilla:

Total Commander:

V primeru, da Total Commander javi napako:

1:SSL_readreturned-1, SSL_get_error=5, ERR_get_error=0

Potrebno je posodobiti OpenSSL knjižnico, navodila.


NOVOSTI 2022 – POMEMBNO OBVESTILO

Pozdravljeni.
Obveščamo Vas, da v letu 2022 pripravljamo številne spremembe, posodobitve, nadgradnje ipd.

Predvidene spremembe v letu 2022:

  • Po 20.05.2022 trajno ukinjamo podporo za PHP 5.6
  • Dodajamo podporo za PHP 8.x
  • Preusmerjamo promet iz protokola HTTP na protokol HTTPS (varna povezava)
  • Postavljamo nove strežnike na SSD NVMe tehnologiji z najnovejšo programsko opremo WHM/cPanel
  • Ukinjamo navadne povezave do poštnega strežnika – na voljo bodo samo šifrirane povezave preko SSL/TLS
  • Ukinjamo navadno povezavo do FTP strežnika – na voljo bo samo šifrirana preko FTPS (SSL/TLS)

S spremembami želimo izboljšati kvaliteto storitev, povečati varnost ter ponuditi novo tehnologijo.

Cena spletnega gostovanja na SSD NVMe tehnologiji za obstoječe uporabnike ostaja nespremenjena.

Spremembe se razlikujejo od uporabnika do uporabnika.